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General Safety Summary

General Safety Summary

Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.
To avoid potential hazards, use this product only as specified.
Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections of the other
component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury

Connect and Disconnect Properly. Connect the probe output to the measurement instrument before connecting the
probe to the circuit under test. Connect the probe reference lead to the circuit under test before connecting the probe
input. Disconnect the probe input and the probe reference lead from the circuit under test before disconnecting the probe
from the measurement instrument.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult
the product manual for further ratings information before making connections to the product.

Do not apply a potential to any terminal, including the common terminal, that exceeds the maximum rating of that terminal.
Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it inspected by
qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.
Do Not Operate in Wet/Damp Conditions.

Do Not Operate in an Explosive Atmosphere.

Keep Product Surfaces Clean and Dry.

Terms in this Manual

These terms may appear in this manual:

c WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

c CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other property.
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Preface

Preface

The TDSHT3 HDMI Compliance Test Software is a High Definition Multimedia Interface (HDMI) Compliance Test Solution,
which runs on a Tektronix oscilloscope. This software helps you perform HDMI physical layer validation and compliance
testing.

NOTE. You will be provided with two TDSHT3 applications, one supporting CTS 1.2a specification displayed as TDSHT3
and the other supporting CTS 1.3a specification displayed as TDSHT3v1.3. Both these applications can be loaded onto
the oscilloscope but you can run only one application at a time. For more information on TDSHT3 supporting CTS1.2a
specification refer to the TDSHT3 HDMI Quick Start User Manual (Tektronix part number: 071-1961-01).

Key Features

Conformance to HDMI 1.3 standards and test specifications (CTS version 1.3) ensures reliable results
Complete validation to standards with wide range of tests for source, sink, and cable devices
Accurate source tests using precise measurement techniques

Dependable sink tests with closed-loop measurements that eliminate nonlinearities in test setup
Automated sink and cable tests with remote control of signal sources

Automatic mask fit, measurements, and pass or fail notification

In-depth analysis with statistical analysis and mask margins

One-button selection of multiple tests

One-button csv-format summary and reports

Complete compliance solution with an elaborate test fixture, signal sources, and TDR

TDSHT3 HDMI Compliance Test Software Quick Start User Manual



Preface

Documentation

This manual describes the installation and basic operation of the TSDHT3 software. For more detailed information, see the
online help. The following information is available for this product:

TDSHT3 Online Help

TDSHT3 Online Help (PDF)

TDSHT3 Quick Start User Manual,

English (PDF) + @
TDSHT3 Quick Start User Manual,
Japanese (PDF)

TDSHT3 Quick Reference Card,
Source Test (PDF)

TDSHT3 Quick Reference Card, = = =l
Sink Test (PDF) C:\ProgramFiles\TekApplications\TDSHT3v1-3\Manuals www.tektronix.com
Installation Manual: Optional

Application Software on
Windows-Based Oscilloscopes

Software Upgrades

Periodic software upgrades may become available. Note that the software is only operational if you have a valid option
key for the specific oscilloscope model and serial number.

To check for upgrades:
1. Go to the Tektronix Web site (www.tektronix.com).
2. Select Software and Drivers.

3. Enter the product name (TDSHT3).
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Install the Software

Install the Software

The TDSHT3 software must be installed on a Tektronix oscilloscope. The following models are supported:
B TDS7254 and TDS7254B

®  TDS7404 and TDS7404B

B CSA7404 and CSAT7404B

® TDS7704B

= TDS6604B

®m  TDS6804B

m TDS6124C

® TDS6154C

= DPO70404 and DSA70404

H  DPO70604 and DSA70604

B DPO71254 and DSA71254

B DPO71604 and DSA71604

= DPO72004 and DSA72004

= DPO70804 and DSA70804 (recommended)

Before Installation

= TekVisa must be installed on the oscilloscope. If you do not have TekVisa, you can download it from the Tektronix Web
site, in the same location as for Software Upgrades. (See page v, Software Upgrades.)

= Please read the Readme.txt file on the product software CD before you install the software.

Installation

. Close all applications.

-

2. Insert the product software CD into the CD drive of the oscilloscope.

3. The installation wizard will guide you through the installation. If this is a version upgrade, the existing software will be
automatically removed before the new version is installed.

4. The software files will be installed at C:\Program Files\TekApplications\TDSHT3v1-3.

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 1



Install the Software

Connect to the Oscilloscope

The various tests require specific equipment setups and specific test adapters. Click More within the connect pane to see
how to connect the device under test and test equipment to your oscilloscope. The following test adapters are required:

®  EFF-HDMI -TPA- R, available from Efficere Technologies (recommended)

= EFF-HDMI -TPA- P, available from Efficere Technologies (recommended)
The test fixtures mentioned below can only work for limited HDMI resolutions.

= Tektronix HDMI TPA-P-DI (for Differential Source tests except Eye Diagram)
®  Tektronix HDMI TPA-P-SE (for Single-Ended Source tests)

= Tektronix HDMI TPA-P-TDR (for TDR tests) and Source tests (Eye Diagram)
®  Tektronix HDMI TPA-R-DI (for Cable tests and Sink tests)

= Tektronix HDMI TPA-R-SE (for Cable tests and Sink tests)

B Tektronix HDMI TPA-R-TDR (for TDR tests and Sink tests)
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Start the Software

To start the TDSHT3 software:

1. For TDS7000-series oscilloscopes,
select File > Run application > HDMI
Compliance Test Software(1.3).

2. For TDS B- and TDS C-series
oscilloscopes, select App > HDMI
Compliance Test Software(1.3).

Install the Software

File  Edit  Verkical Horiz/Acq Measure  Masks  Math  Lkiities  Help

Reference Waveforms 4 — -

Instrurment Setup. ..
Recall Default Setup

Run Applicatio

Page Setup...
Prink Preview
Print... Cerl+p

USBZ.0 Test Package

Export Setup...
Select for Export 3
Export...

1 Recent Setup Fle 1

Minimize Cerl+i

Shutdown, ..

1961-003

File Edit Vert Horz/Acq Trig Display Cursor Meas Mask Math | App MyScope Utilities Help Button

Restore Application, |

Ci icati Pulse 2
Ethernet Compliance Test Software
HDMI Compliance Test Software

HDMI Compliance Test Software(1.3)
Jitter Analysis - Advanced
Jitter Analysis - Essentials
Protocol Trigger and Decode
USB2.0 Test Package

Il 20mv #

1961004
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Install the Software

3. For DPO70000 and DSA70000-series
oscilloscopes, select Analyze > HDMI
Compliance Test Software(1.3).

4. The oscilloscope display resizes to fit in

the upper part of the screen.

5. The software displays in the lower part of

the screen.

mplitude +
|
Conneot
S 3 mplitude -

USB20 Test Package
RIT-6v8 S Coneaance and Analysis

D42 Complonce Test Sobsion

Etnerne Conpionce Test Software

HOM Conplance Test Sottware

e Anaysis

Frotoco T and Decode

A st L Teme vt Protocsd Dscods Somtwe.
00 Comphance Test Software(13)

[Epr—

4 Be1606 O
4 Beteoc A

O 20mv 2
D 132mV 50.0ps 10.1ms 96ms

RL:100K

200nsipt

1961006

File  Edit  Wertical Haotizfacg  Trig  Display  Cursors  Measure  Masks Math  Utilities

File Tests Results Utilities Help TDSHT3

a-Data Tests Single-Ended Tests

Intra-Pair Skeuy

Source -x Eye Diagram Clock-# Ch1; Dats -> Ch2; Res Length -> 18h; CRU -2 PLL

Help

m| x|

Result

Summary
D etail

1961-006

NOTE. To ensure accurate results, calibrate the probes and the oscilloscope before you run tests.
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Calibrate the Probes and
Oscilloscope

6.

File

Edit

Click Utilities > Instrument Calibration
to begin calibrating the oscilloscope for
signal path compensation.

Click Calibrate.

8. Select Vertical > Probe Cal to begin
calibrating the probes.

9. Connect the probe calibration signal to
the probe.

10. Click Calibrate Probe. He Edt

——
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Install the Software

Horiz/Acq Trig Display Cursors Measure  Masks Math Liilties  Help
07 Jun 04 1

Werkical

Tek Secure Erase. .

Set Time & Date...
iaPIE Configuration, ..
LAN Server Status...
External Signals.

Instrurment Diagnostics. ..

Dieassign Multipurpose Knobs

User Preferences. .,

©ption Installation, ..

Calibration Instructions
Status

Calibrate

1961007

File Edit Vertical Horiz/Acq Trig Display Cursors Measure  Masks  Math Lkilities Help

Vertical Setup... 21 Jun 04 11

Zoom Controls...

Position

App

Display OnfOFF. ..
Pasition/Scale...

Label...
Factor

Offset...
Termination. ..
Coupling. ..
Bandwidth

Deskew,
Attenuation...

Zoom Setup...
Zoom Graticule Size *

1961008

Yertical Cursors Ukilities Help

)

Position

Display

Hariz/Acq

Trig Measure  Masks  Math

21 Jun 04 11 8

by i eghuryly w-w\-w'ww

(I gt

Factor

Initi
Clear Probecal

Calibrate Probe

‘v\i‘ﬂ‘v,pwuln

| !
‘W*’\i .lm"y'i\. ..‘-,‘

1961009
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Install the Software

Close the Software

1. Select File > Exit.

2. You can also click the exit icon.

Using other methods to exit the software
will result in abnormal termination.

3. When you exit the software, you
can restore the oscilloscope to the
settings that were in place before the
TDSHTS3 software changed them.

Recall Default ; v
PGl Clock-D Data-Data Tests Single-Ended Tests Test
Save... .
PR = Diagram ¢ Jithe er-P Intra-Pair
ReczllRecent » Result

File Tests Results Utililies Help TDSHT3

Preferences mplitude + Report—

Minirmize

it
|

Source -* Eye Diagram Clock-* Ch1; Data -* Ch2; Rec Length -* 16M; CRU -5 PLL

Do you want to restore the oscilloscope settings to
their state prior to starting this application?

1961-010
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Get Acquainted with the Software

Get Acquainted with the Software

Use the Interface
Use a keyboard, mouse, or touchscreen to make selections in the TDSHT3 software.

Use menus, check boxes, and on-screen buttons to control the software functions. Use Microsoft Windows techniques to
navigate menus and select or clear check boxes.

Device under test (DUT) type Client pane Executlon pane

Menubar —— sie | Tests Results Utilies He p TDSHT3 |E”_||
[ -

.
Differential Tests ¢ Single-Ended Tests
s ng .
- Jitter Tolerance Intra-F air £
Configure |

Selection pane -

Wi
Waveform

Status bar - Sk -= MindMaxDiff Swing T... Input-= Ch1

1961-011

Virtual Keyboard

1. C“Ck NeW File Tests Results Ulilities Help TDSHT3 E] LI

Configure-DTG Pattern List

Pattern Run
Test

Available Patterns

Report —

Connect Delete

Selected
Wiew
W aveform

Utilities -» DTG Pattern Confi

2. Clear the existing text and type the new DTG Pattern ath

ST T
-~ &
3. Click Enter to confirm your selection. H - ] -

Cepetock -n.-
< > =
z X C Y

1961013
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Get Acquainted with the Software

NOTE. You must click Enter on the virtual keyboard; otherwise your selections are not valid.

Virtual Keypad

1. Click any number box.

File Tests Results Utility

o m x|
1 i “ “ o A‘C(‘:Uu"ﬁu‘-"e seuree Reference Levels
2. Click the keypad icon.

Run
Test

® -
0% ” Report—
—

Summany
Wiew - 20%
Wavetorm i

Detail

Source -* Multiple Tests Clock-= Ch1; Data -» ChZ; Rec Length -> 16M; CRU - PLL; High -= 20%; Low -> 20%

1961014

Clear existing value and enter the value
desired.

4. Select a unit of measure.

5. Click Enter to confirm your selection.

1961-015

NOTE. You must click Enter on the virtual keypad, otherwise your selections are not valid.
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General Purpose Knob

1. Click any number box to display the
connection to one of the general purpose
knobs.

2. Turn the corresponding knob on the
oscilloscope front panel to adjust the
value for the selected parameter.

3. For better resolution, press the FINE
button.

Set Preferences

1. From the TDSHT3 software menu bar,
click File > Preferences, and then select
an option.

2. Click the option again to clear the
selection.

Option

Get Acquainted with the Software

File | Tests Results Uilities Help
Input

-
Clock
Ch1 W

Wiew

TDSHT3 I S
Configure - Source
Horiz/Acq Reference Levels

#of Acqgs ® Units High

Rec Leg s

16.0M ¥

Run
Test

Report—

Summary

Hysteresis Detail

W awetarm

Source -» Eye Diagram Clack-> Cf

1961016

N
[0 e00lB B B B - |

1961-017

File Testz Results Utilities Help

TDSHT3 B x|
Run
Test

Report—|

Recall Default ure - Cable

& Equalize Time Filter

Recall...

Save...

Recall Recert » j Clock Datal

LY 4 Y 4

Minimize Acguisition Alert Message Data? Summary

Exit Jitter Talerance (Mo calibration) 1w

I Single Ended {ith 500hm termy)

Cable -» Eye Diagram Clock-» Ch1; Data -» ChZ; Rec Length-* 16h; CRU -» PLL; TF1 -* True; TPZ -» True

Description

Position Eye Mask in Center

Selected: Positions the mask at the center of the eye diagram.
Cleared: Positions the mask to the left of the eye diagram.

Acquisition Alert Message

Selected: An alert prompts you to specify oscilloscope settings with which
to run the test.

Cleared: TDSHT3 software selects oscilloscope settings.

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 9



Get Acquainted with the Software

Option Description

Jitter Tolerance (No calibration) Selected: Application will not run the jitter calibration test for Sink Jitter
Tolerance measurements.
Cleared: Application will run the jitter calibration test for Sink Jitter
Tolerance measurements.

Single Ended (With 50ohm term) This option can be selected only when the negative input of the probe is
terminated with the 50 ohm terminator.

Selected: Application will run the single-ended measurements as though
50 ohm termination is connected.

Cleared: Application will run the single-ended measurements without
50 ohm termination.

Hide and Return the TDSHT3 Software

1. Click the hide icon to minimize the
TDSHT3 software and enlarge the @

oscilloscope display.
P piay. File | Tests Results Utilities Help TDSHT3 am x|

Configure - Source
Horiz/Acq Reference Levels

#of Acgs .4
1h L2

Rec Length

Source -» Multiple Tests Clock-» Ch1; Data-» Ch2; Rec Length -= 1GM; CRU -» PLL; High -» 80%; Low -» 20%

1961-019

To return to the TDSHT3 software:

2. For TDS7000-series OSCi”OSCOpeS, Fle Edt Vertcal  HorizfAcy  Trig  Display  Cursors  Measurs  Masks Math  Ublities  Help
se'ect the APP button ek Stopped Single Ge 1 hogs

Wirlary Gl r,\'V"'"N'.._uM\lh'n,v'

IT 10.0pshat

1961-020
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Get Acquainted with the Software

3. For TDS6000B/C and TDS7000/B-series

File Edit Vert Horz/Acq Trig Display Cursor Meas Mask Math RN MyScope Utilities Help Button

oscilloscopes, select App > Restore O —
. . DVI Compliance Test Solution
Appl |cat|on . Ethernet zompliance Test Software

HDMI Compliance Test Software
HDMI Compliance Test Software(1.3)
Jitter Analysis - Advanced

Jitter Analysis - Essentials

RT-Eye Serial Compliance and Analysis
UWB WiMedia2

1961-021

4. For DPO70000 series oscilloscopes,
select Analyze > Restore Application.

USB20 Test Package

RT-Eye Sersl Congamice s Analysi

Frotocol Trigger and Decode

ctd Dacoste Softwice

Select - Source

Data-Data Tests Single-Ended Tests

Source -> Eye Diagram Clock -> Chi, Data -> Ch2, Rec Lenath -> 320, CRU-> PLL

1961022
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Use the TDSHT3 HDMI Software

Use the TDSHT3 HDMI Software

Tests: Process Flow

When you make a test, follow the sequence of actions indicated in steps 1 through 6. Details for each of these actions
are given on the following pages.

1.

N o o 2w bd

Select a test.

Configure the test parameters.
Connect and configure the equipment.
View the waveform to verify test signal.
Run the test.

Interpret the test result.

Generate a report.

Source Sink
ﬁ = it [ Tests Single-Ended Tests

@ ®

File |fests Results Utliies Help TDSHT3 | x|
5 on

_Select - Source
=111

NOTE. For accurate test results, calibrate the oscilloscope and probes before you begin the tests. (See page 5, Calibrate
the Probes and Oscilloscope.)

Select a Test

12

Click Select.
Click the Source, Sink, or Cable tab.

Move the mouse near a test name
until the test ID appears. This ID
corresponds to the Test ID in the HDMI
ComplianceTestSpecifications.

Select the test that you want to run.

You can select multiple tests, but they
must all be of the same type.

To select all tests of a certain type, click
Select All.

® @0

File [lests Results Utilites Help TDSHT3 EJ X

Select _Source

e-nata Tests Single-Ended Tests

Inter-P

1961024
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Use the TDSHT3 HDMI Software

Configure the Test Parameters

1. Click Configure. File | Tests Results Utilities Help TDSHT3 m| x|
Configure - Source
2. Use the virtual keyboard or the general ot i n
purpose knob on the oscilloscope front )

panel to change the values if necessary. | e Lents

. 16.0M W
You can also use the File menu to restore |2 |
factory defaults or save and recall your
own configuration settings.

CRU
‘ PLL ¥

urce -> Eye Diagram Clock-* Ch1; Data-* Ch2; Rec Length -> 16M; CRU -> PLL
1961-025

Connect and Configure the Equipment

NOTE. If your test uses remote control, the setup diagram in the online help shows how to connect the test equipment by
using an E-net connection. You can either use this method or you can use the GPIB-B connection. (See page 34, Enable
Remote Control of Test Equipment.) Example tests are shown in the Application Examples section. (See page 19.)

1. Click Connect.
2. Follow the on-screen instructions to e | Teste Resuls [iifies Help TDSHT3 x|

connect and configure the device under
test and the test equipment.

3. Click More to view the online help for
the selected test, which contains a setup .
diagram. Connect the test equipment as
shown in the diagram.

Sink -> Jitter Tolerance Freq Pair> D,CK: 500kHz, 10MHz: DUT freq-> 74.26MHz; Test Opt.-» Alternative-1 ; Jitter Insertion-»

4. If the AWG/AFG and DTG are used for o
the selected test, select Signal Sources
and configure the test equipment. (See
page 34, Enable Remote Control of Test
Equipment.)

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 13



Use the TDSHT3 HDMI Software

View the Waveform

1. C“Ck VieW Waveform (nOt applicable f0r File  Edit  Wertical Horizfacg  Trig  Display — Cursors  Measure  Masks  Math  Utilities  Help
all tests). : s

2. \Verify that the waveform in the upper part
of display is similar to the waveform that
is displayed in the TDSHT3 software.

If the displays are not similar, check your
configuration and connections.

Run
Test
Result

Summary
Detail

1961-027

Source - InterFair Skew(D,D)  Data0-* Ch2; Data 1-* Chek Thit 3.7037ns

Run the Test

1. Click Run Test.
File Testz Results LUHilities Help

2. The test will run, displaying a progress
indicator. Salact

Run
Test

Current Test gram Result

Completed: 0 out of 1 Tests)
Summary
Detail

1961028

Configure

Connect

Wi

Ll

Waveform

Source -» Eye Diagram Clock -> Ref1; Data -* Ref2; CRU -» PLL
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Use the TDSHT3 HDMI Software

Interpret the Test Result
1. When the test completes, the Result

Summary appears. Check to see if the
device passed the test. ——

L /17-10: [ata Eye Diagram: CK, D
means Pass

B means Fail

File Tests Results Utilities Help

Result Sumniany: Source

means Error

If the device did not pass the test, use Sauree s Eve Diagtam ——
steps 2 through 8 to solve the problem, ' “jgpto00
and then rerun the test.

2. Click Result Details for a spreadsheet
with details about the test result.

Result Details

3. Check the Remarks column. If any error — : e
codes are present, see the online help ST Record Lengih =
for error code descriptions.

1961-060

NOTE. The parameters in the Result Details dialog box may change depending on the test that you run.
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Use the TDSHT3 HDMI Software

16

If you ran an eye diagram test, a plot
appears. You can do the following:

4.

10.

Save the image to C:\TekApplica-
tions\TDSHT3v1-3\Images (you can also
change this path).

Zoom in and out.
View the histogram.

Move the mask to see the margin of
error.

View statistics.

Change the plot to half screen size
(which returns the Result Summary).

A plot also appears if you ran the clock
jitter test. In this plot, you will find the
peak-to-peak jitter of the clock.

Yoltage [175mY/div]

-

Mask Manual Fit
Mask Movement

Fine

[

Reset]
I ask|

Resulis
Mask Test

Mask Hits 0
Vswing  996.96mV

Thit 3.703Tns

Data Jitter 55.1ps

Hist Pk-Pk  55.1ps

- .TI!TIE.[T41[JS v |

Half Screen

1961-061

Clock Jitter

Results
Result
Pk-Pk 37.2ps
Vswing 908.80mV

z
=
>
£
5
I~
@
=3
2
o
>

Thit 3T03Tns

-

ITPk-Pk 32.181ps

Hist Pk-Pk 37.2ps

= Time [370ps/div]
alf Sereen

1961-062
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Use the TDSHT3 HDMI Software

Generate and Print a Report
You can generate and print a summary or detailed report as described here.

You can also use the Report Generator to create and print customized reports. You can save files as RTF, or in custom file
formats such as RGT, RPL, and RPT. For more information about the Report Generator, see online help.

Summary

After you have successfully run a test or tests, you can generate a report summary as a .csv file.

1. Click Summary in the execution pane. File Tests Results Utiities Help TDSHT3 m| x|
Result Summal
2. A message indicates where the report steo R
summary is saved. -
Configure s
3. Open the file and print the report. [ o |
Connect

Wieww
Wiaveform
ou

Detail

After you run a test, you can generate a report that contains default information or information that you configure.

1. Click Result to begin configuring the

report (or skip to step 14 for defaults). P ——
Ep0o anfiguration

2. Select the input on which you conducted Pair (CK, D) Datan
the test. '

Resolution
3. Enter the resolution at which you

conducted the test (such as 40 Hz, Refresh Rate  B0Hz
43 Hz, 57 Hz, or 60 Hz).

Report File neraton

4. Enter the refresh rate at which you
conducted the test (such as VGA, SVGA,
XGA, or SXGA).

5. Note the location where the report will :R@"" @ .
be saved; you can change the location

if desired.

6. Select Enable Preview to view the report
on screen when the report is generated.

7. Click Clear Report to clear all reports.
Reports generated between this and the
next successful test run will have no
values.

8. Click Advanced.

TDSHT3 HDMI Compliance Test Software Quick Start User Manual 17



Use the TDSHT3 HDMI Software

10.
1.

12.

13.

14.

Enter the DUT ID (serial number).
Enter the DUT details (product type).

Enter the pair(s) that you are using
for single-ended and differential tests.
These entries correspond to the
connectors on the HDMI adapter; see
the setup diagrams.

When this check box is cleared, the
TDSHT3 software configures the
oscilloscope to display jpeg images

in reports.If you want to change the
default image export settings, change
the settings in the oscilloscope image
export setup and check this check box.

Click OK.

Click Detail in the report pane to generate
the report.

E |f Enable Preview is selected, the
Report Viewer utility displays the
report. Otherwise, a dialog box
displays the location where the
report was saved.

®  For an eye diagram or clock jitter
test, a plot is also displayed.

®  You can use the Report Viewer Edit
menu to edit the report, if desired.

= Use the Report Viewer File menu to
print the report or export the report
to an RTF file.

Report Configuration Advanced...

Device 10

Device Details

HO M Device

Pair (Single-Ended)

Pair (D, D}

TOSHTZ_001

[ratad

[ratal - [atad

T Uze azcilloscope settings for image export

Cancel

1961035

[ Report - Report Yiewer |5 x|
File Edit view oObject Help
%Ry S AR S]E R E e

=

Test ID/Name: 7-10: Data Eye Diagram : CK D

Spec Hange
Meas Value :

Fesult :

Thit

Vewing

1

Data Jitter = 0.3 TEit;

0.27922*TEit

1.0000ns
WeD =564 48mV

| o

Ready

Peee Tors [T

1961-066

NOTE. The report details are real time and no history is maintained. Save the report details before making another test.
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Application Examples

Source: Select All (Clock-Data Tests)

This selection runs a set of tests simultaneously.

Application Examples

Required equipment

Example

2 differential probes; Ground lead

Tektronix P7313SMA/P7350SMA (P7330/P7350/P7380/P7380SMA with
external circuit can only be used with old fixtures);
Tektronix part number 196-3469-00

1 DC power supply, setto 3.3V

Kenwood PW18-1.8AQ

1 EDID emulator

EFF-EDID PCB(INFO)/Silicon Image TE9100/Quantum Data 882CA

1 input adapter

EFF-HDMI -TPA-P available from Efficere Technologies

Probe Calibration and Deskew fixture

Tektronix part number 067-1478-XX

1. Click Select.
2. Click the Source tab.
3. Click Select All.

4. Click Configure. Change these values
if needed. (You can generally use the
default values.)

TDSHT3 m| x|

@File Tests Results Utilities He
= _Select - Source
( Sink Cable
elec

Data-Data T
nnnnn

Source -» No Tests selected

Tk

Souree -» Multiple Tests Clack-» Chi; Data -» Ch2; Rec Length -> 164

1961-037

File Tests Results Utilities Help TDSHT3
Configure - Source
Horizifcq Reference Levels

@ #of Acgs ® Units High
L3 80%

n Par (%) ¥

Hysteresis & i
e tysteresi ’ Mid
ok, 10% 50%

Connect

View
W aveform

Source -> Multiple Tesis

Clock-= Ch1; Data -> ChZ; Rec Length -> 16M; CRU -» FLL; High -» 80%; Low-= 20%

TDSHT3 HDMI Compliance Test Software Quick Start User Manual
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Application Examples

5. Click Connect. File Tesls Results Uliifies Help TDSHT3 m x|

Connect

Follow these instructions to set up the connections.

@

Connect

Wiew
Waveform

Source -* Multiple Tests

Clock-* Ch1; Data -* Ch2; Rec Length -* 16M; CRU -5 PLL; High -> 80%:; Low-* 20%

1961033

6. Connect and configure the equipment: Digial Osciloscops

T r———

®  Connect the test equipment as
shown in the setup diagram.

®  Configure the source DUT to output
the first supported video format.

®  Connect the Efficere EDID PCB with
the EDID chip or configure the EDID
Emulator for the required resolution
(refer to the EDID Emulator user
manual).

NOTE. In the diagram, the symbol
represents a connection to a biased 50 Q
termination, such as an input port of an
unoccupied differential SMA probe.

BjzedEaey |NGH
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7. Click View Waveform.

Verify that the oscilloscope displays a
similar waveform to the one displayed by
the TDSHT3 software. If the displays are
not similar, check your configuration and
connections.

To ensure accurate results, deskew the
probes before you run a test.

8. Click Run Test.

9. When the test completes, check the test
results. (See page 15, Interpret the Test
Result.)

10. You can generate reports based on
the tests that you ran. (See page 17,
Generate and Print a Report.)

11. After you test the Data0 input pair, move
the probe from Data0 to Data1 and
repeat the test. Repeat for Data?2.

12. Configure the EDID Emulator for the
next pixel clock rate ( VGA, SVGA, and
so on), and test for all three data input
pairs. Only one video format is required
per pixel clock rate.

13. Repeat step 12 for all supported pixel
clock rates.

Application Examples

File  Edit

Wertical
Sample

Cursors  Measure

Hatizfacg  Trig  Display b Utlities  Help

ek Run

File Tests Results Utilities Help TDSHT3

|y x|

View Waveform

Waveform shouid look like the signal§) as shown, Click More for det;

nnnnn

D etail

1961041

Source -* Multiple Tests Clock-* Ch1; Data -* Ch2; Rec Length -* 16M; CRU -* PLL; High -* 80%; Low -* 20%

File Tests Results Ulilities | Help TDSHT3

Report Configuration
I—' i
Test

Resolution 14

Pair (CK, D)

[7-4. Rize Time: D
[7-4: FallTime: Ch
[7-4: FallTime: [

Refresh Rate

nnnnn

Report File

Source: Inter-Pair Skew (Data-Data Tests)
This test verifies that the skew between the differential pairs in the TMDS portion of the HDMI link is within the limits

stated in the HDMI Specifications.

Required equipment

Example

2 differential probes; Ground lead

Tektronix P7313SMA/P7350SMA (P7330/P7350/P7380//P7380SMA with
external circuit can be used with old fixtures);
Tektronix part number 196-3469-00

1 DC power supply, setto 3.3V

Kenwood PW18-1.8AQ

TDSHT3 HDMI Compliance Test Software Quick Start User Manual
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Required equipment

Example

1 EDID emulator

EFF-EDID PCB(INFO)/Silicon Image TE9100/Quantum Data 882CA

1 input adapter

EFF-HDMI -TPA-P available from Efficere Technologies

1. Click Select.
2. Click the Source tab.

3. Select Inter-Pair Skew.

4, Click Configure. Change these values
if needed. (You can generally use the
default values.)

5. Click Connect.

22

@ @

File | Tests Results |Ulilities Help TDSHT3

-Data Tests Single-Ended Tests

cdifter Kmppa

o

Wiew
‘ifaveform Select All

Source -» InterPair Skew(D,0)  Data0.» Ch1; Data 1 -» ChZ; Clock-» Ch1; Thit: Recale; Avgs-= 100

File Tests Utilities Help TDSHT3 | X
Configure - Source

Input Horiz/Acq Reference Levels Run
Select " .
Data Pair #of Acqs (.3 Units High Test
o L3
L3

oo -

Thit Report—

#of Avgs
Conneot Re- :
- Chz 100 L Seammany
Wiew Clock Exigting, Detail
Wavefarm Ch1 ¥ Yalue i

Source -> Inter-Pair Skew0.D)  Data0-» Chi: Data 1-» Ch2; Clock-> Ch: Thit Recale Awgs-> 100

1961044

1961-045

File Tests Results Utilities Help TDSHT3

| x|
Connect

Follow these instructions to set up the connections.
-

Report—
View
W aveform
Source - InterF 4

Summany

D) Datad-= Chi; Data 1-> Ch2; Clock-> Chi; Thbit: Recale; Avgs -> 100

1961-046
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6. Connect and configure the equipment:

m  Connect the test equipment as
shown in the setup diagram.

= Configure the source DUT to output
a video format with the highest
supported pixel clock frequency.

®  Connect the Efficere Technologies
EDID PCB with the EDID chip or
configure the EDID Emulator for the
required resolution (refer to the EDID
Emulator user manual).

NOTE. In the diagram, the symbol
represents a connection to a biased 50 Q
termination, such as an input port of an
unoccupied differential SMA probe.

7. Click View Waveform.

Verify that the oscilloscope displays a
similar waveform to the one displayed by
the TDSHT3 software. If the displays are
not similar, check your configuration and
connections.

Application Examples

Digital Qaciloscope

(e X-A[losle)
DDO(J-.‘J

Porwer Supply T

Qo000

DETA_N

DATA P

HOMI- TPA-F
DiTAZ P

ATAY P
DATALN

| |l DATAO_P
[ DATAD N

T f CLOCK P

CLOCK N

Bjoayd ey |INOH

EDID Emulator

File  Edit  Wertical Haotizfacg  Trig  Display — Cursors  Measure  Masks  Math

Tek __FRun

TDSHT3

View Waveform

Waveform shouid jook iike the signai &) as shown, Click NMbre for details.

Source - InterFair Skew(D,D)  Data0-* Ch2; Data 1-* Chek Thit 3.7037ns

DATA? W

pull up
pull up

pull up
pull up

Utiities ~ Help

m| x|

Run
Test
Result

Summary
Detail

TDSHT3 HDMI Compliance Test Software Quick Start User Manual
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Application Examples

Sink

24

Recalculate the Thit value:

8.
9.

10.

1.

12.

13.

Click Configure again.

Check that the software is set (default) to
recalculate the Thit value.

If your signal has too much jitter and
noise, increase the value in this box
(default = 100).

Click Run Test and then click Continue
to run the test with the new Thit value.

When the test completes, check the test
results. (See page 15, Interpret the Test
Result.)

You can generate reports based on
the tests that you ran. (See page 17,
Generate and Print a Report.)

File Tests Results Utilities Help
Configure - Source

TDSHT3 LTS
Input HoriziAeq Reference Levels
Data Pair
\ ‘ Lo-D1 W
| Ceonfigure -

HofAcgs & Units High
4  Fer ) ¥
Thit
Re. #of Avgs ff ®
caleulate 100 L

urce -* InterPair Skew(D,D) Datad-= Chi; Data 1-> Ch2Z; Clock-> Ch1; Thit: Recale; Avgs -> 100

Hysteresis & Mid
10% L

nnnnn

Low

File Tests Results Utifties Help

Refresh Rate

Report File

& Enabie

Source - Inter-Fair Skew(D,D)  Data 0-> ChZ; Data 1-> Ch3; Thit: 3.7037ns

Min/Max-Diff Swing Tolerance Test

This test verifies that the sink device properly supports TMDS differential voltages at minimum levels.

Required equipment

Example

Digital Timing Generator

Tektronix DTG5274 (up to 2.7 Gb)/DTG5334 (up to 3.4 Gb) with DTGM30
output module

8 SMA cables

Tektronix part number 174-1341-00, 1 meter, or
Tektronix part number 174-1428-00, 1.5 meters

1 DC power supply, setto 5.0 V

Kenwood PW18-1.8AQ

1 input adapter

EFF-HDMI -TPA-P available from Efficere Technologies

TDSHT3 HDMI Compliance Test Software Quick Start User Manual



1. Click Select.
2. Click the Sink tab.
3. Select Min/Max-Diff Swing Tolerance.

4, Click Configure. Change these values
if needed. (You can generally use the
default values.)

5. Click Connect.

File ‘esls Resfits Utilities  Help

Select [
Differential Tests

Configure
Wien
W avetorm

Sink -> Min/taxDiff Swing T... Input-» Ch1

Application Examples

TDSHT3

single-Ended Tests Test

Result

Report—|

Summarny

Detail

1961051

File Tests Results Utilities Help

TDSHT3 m| x|

Configure - Sink

DTG Run
Pattern Outputs Test

Clock Datal

Ch

Configure () Sa— M‘ )
L T

View

Waveform

Sink -= Min/MasDiff Swing T...

Input-* Ch1

File Tests Results LUtilities Help

Connect

Follow these instructions to set up the connections.

1. Setup the DUT, te

< Diff Swing T... Input-» Chi

TDSHT3 HDMI Compliance Test Software Quick Start User Manual

Select From List
— Al v Al Result

0Hz 2Bit Gray... ¥

Data2 Report—|
c1 -
Summary

Detail

1961-052

TDSHT3 | x|

Run
Test

Report—

Summary

Detail

1961-053
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Application Examples

6. Connect and configure the equipment:

m  Connect the test equipment as
shown in the diagram.

= Connect the DTG and oscilloscope.
(See page 34, Enable Remote
Control of Test Equipment.)

Sink DUT

Wwae

7. Click Run Test. @ @

8. Follow the series of on-screen messages. e S—— e —— m
Result Sumnjry: Sink
9. When the test completes, check the test = T
results. (See page 15, Interpret the Test Resontion
Result.)
Refresh Rate
10. You can generate reports based on [ —— Report File

the tests that you ran.(See page 17,
Generate and Print a Report.)

Sink -= Min/Masx-Diff Swing T... Input-* Ch1

NOTE. When you run sink or cable tests, a warning about GPIB Bus Timing appears. If you are sure that the bus timing
parameter is set to 2 msec, click OK to continue. Otherwise, click Cancel and change the bus timing parameter. (See
page 39, Set the GPIB Bus Timing.)

Sink: Jitter Tolerance Test

This test verifies that your device supports the maximum allowed TMDS clock jitter.

Required equipment Example

Digital Timing Generator Tektronix DTG5274 (up to 2.7 Gb)/DTG5334 (up to 3.4 Gb) with DTGM30
and DTGM32 (for use with AWG710/AWG710B/AFG3000 only) output
module

Arbitrary Waveform Generator Tektronix AWG710 or AWG710B or AWGT7102 (Separate Jitter insertion)

Arbitrary Function Generator Tektronix AFG3102, AFG3022, AFG3252

12 SMA cables Tektronix part number 174-1341-00, 1 meter, or
Tektronix part number 174-1428-00, 1.5 meters

1 cable emulator As described in CTS1.3

2 bias tees Mini-circuits ZFBT-4R2GW
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Required equipment

Application Examples

Example

1 DC power supply, setto 5V

Kenwood PW18-1.8AQ

2 input adapters

EFF-HDMI -TPA-P and EFF-HDMI -TPA-R available from Efficere
Technologies

1. Click Select.
2. Click the Sink tab.

3. Select Jitter Tolerance.

4, Click Configure. Change these values
if needed. (You can generally use the
default values.)

5. Click the DTG tab and configure the DTG
outputs that will provide the clock and
data input signals.

6. Click Connect.

File ["ests Results Utilities Hela

Select
Single-Ended Tests

ditter Tolerance - Intra-P air Skew
Result

Report—|

View
Waveform

Sink-> Jitter Tolerance Freq Pair-> D,CK: 500kHz,10MHz; DUT freq-> 74.25MHz; Test Opt-> Alternative-l ; Jitter Insertion-> ...
1961-056

TDSHT3 IEJ L”

File Tesis Results Utilities Help

Configure - Sink

4 ~r (R
m / [ o= -
i Jitter Insertion Jitter Amplitude

Frequency

D,CK: S00kHZ,10MHz ¥ Composite
Configure Clock L

== ' .
Connect

Separate

260mThit

Sink -> Jitter Tolerance Freq Pair-= D,CH: S00kHz, 10MHzZ; DUT freg-* 74.25MHz; Test Opt.-* Alternative-l ; Jitter Insertion-> ...
1961057

File Tests Results Ulilities Help TDSHT3 m %
Gbnfigure - Sink
m [“setup [~ oTe

Pattern Qutputs
Configure . Clock Datall
Select From List CU 4 B1 v

e -
ey Datal Data2

B2 1w
Wiew
Wiaveform

Sink-> Jitter Tolerance Freq Pair-» [,CK: 500kHz, 10MHz: DUT freq-* 74.25MHz; Test Opt-* Alternative-l ; Jitter Insertion-> ...
1961058

File Tests Results Utilities Help TDSHT3 Ej X

Connect
—_ i i Run
== Test

Report—

Summary

Detail

View
W/ aveform

Sink -> Jitter Tolerance Freg Pair> D,CK: S00kHz, 10MHz; DUT freq-> 74.25MHz; Test Opt.-> Altenative-| ; Jitter Insertion-= ...
1961-059
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7. Connect and configure the equipment:

NOTE. In the diagram, the symbol
represents a connection to a biased 50 Q
termination, such as an input port of an
unoccupied differential SMA probe.

Jitier Generation

= Use Jitter Generation block to
generate a known amount of jitter
(Clock jitter: 0.25 Ul, Data jitter:
0.30 UlI).

= Connect the test fixture to the
oscilloscope for calibration. The
oscilloscope calculates data and
clock jitter inserted due to the cables
and the test fixtures along with the
known amount of jitter.

8. Connect and configure the equipment in e
one of the following methods: ‘
Method 1a: DTG-AWG710/AWG710B ‘
for testing resolutions <74.25 MHz > oedlan

[©] pTemao dr}

= Connect the test equipment to the
DTG and AWG as shown in the
setup diagram.

M1

M2

Power Supply

= When connecting the test fixture S 00.00

to the DUT, use a cable emulator
specified for the pixel clock rate oo (oo HOMLTPA®
being tested. . o=

= Connect the DTG, AWG, and H :
oscilloscope according to the Enable
Remote Control of Test Equipment
procedure. (See page 34.)

Sink DUT

Nua

B Configure the DUT to receive the
HDMI input signal.

28 TDSHT3 HDMI Compliance Test Software Quick Start User Manual



Application Examples

Method 1b: DTG-AWG710/AWG710B
for testing resolutions >74.25 MHz

AWG 710/ ANG710B

®  Connect the test equipment to the
DTG and AWG as shown in the
setup diagram.

®  When connecting the test fixture
to the DUT, use a cable emulator
specified for the pixel clock rate
being tested.

m  Connect the DTG, AWG, and
oscilloscope according to the Enable i
Remote Control of Test Equipment LH
procedure. (See page 34.)

-
3
o
=
3
a8
=
@
@

Cable Emulator Sink DUT

i
D1
B
B1
B2

[

|

OO0

) - -}

Waa

B

— o
o

m  Configure the DUT to receive the
HDMI input signal.

Method 2: DTG-AFG3000 composite _bte

jitter insertion {

H  Connect the test equipment to the e o aT
DTG and AFG as shown in the setup © ' J
diagram. 32

m  When connecting the test fixture
to the DUT, use a cable emulator
specified for the pixel clock rate

being tested.

®  Connect the DTG, AFG, and TTCModules - Cable Emutor Sink DUT
oscilloscope according to the Enable L — >
Remote Control of Test Equipment M - -

procedure. (See page 34.) — o

R

= Configure the DUT to receive the
HDMI input signal.
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Method 3: DTG-AWG7102 composite ot ; ~Awertoz
jitter insertion for all frequencies

B Connect the test equipment to the

DTG and AWG7102 as showninthe = s oty ===
Setup diagram_ \w@?@T@ 0000000000 0m|e D
®  When connecting the test fixture
to the DUT, use a cable emulator gadll
specified for the pixel clock rate H ﬁ
being tested.
= Connect the DTG, AWGT7102, and 55| e
oscilloscope according to the Enable L e R
Remote Control of Test Equipment L == ———c oL
procedure. (See page 34.) = e——=
— — MIJ
m  Configure the DUT to receive the
HDMI input signal.
Method 4. DTG-AWG7102 separate ore i _ Awerto2

jitter insertion for all frequencies

B Connect the test equipment to the ——— =
DTG and AWG7102 as shown inthe /o dhi fhun o | L2 Rl
setup diagram. ”OTO
= When connecting the test fixture
to the DUT, use a cable emulator rtess|| | o
specified for the pixel clock rate mmm]w ﬁ
being tested.
= Connect the DTG, ANG7102, and so 7 e
oscilloscope according to the Enable i M— s R
Remote Control of Test Equipment === E_ iy
procedure. (See page 34.) _q:::.—<_:* :‘L?“E —

= Configure the DUT to receive the
HDMI input signal.

9. Click Run Test.

10. Follow the series of on-screen messages. e Tests Resutte UtIES] Help
Result Summanyl Sink Report Configuration
11. When the test completes, check the test oot | — Trra— L R B
results. (See page 15, Interpret the Test o Resolution
R eSUI t) Refresh Rate Report—
12. You can generate reports based on Sepertie
the tests that you ran. (See page 17, 2 Enabie Freview :
Genel’ate and Print a Report) ink > litter Tolerance rea Pair.> Both: DUT frea-» 74.25MHz: Test Oot-> Altemative-l : Jitter Insertion-> Como osite-AING

1961-066
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NOTE. When you run sink or cable tests, a warning about GPIB Bus Timing appears. If you are sure that the bus timing

parameter is set to 2 msec, click OK to continue. Otherwise, click Cancel and change the bus timing parameter. (See

page 39, Set the GPIB Bus Timing.)

Cable: Eye Diagram Test

Cable Equalizer

The signal degradation of typical passive copper cables increases with the frequency and the length of the cable. To recover
data from such cables, the TDSHT3 applies the reference cable equalizer as specified in the HDMI specification 1.3 to Eye

Diagram measurement when the clock frequency is more than 165 MHz.

This test verifies that the cable assembly outputs a compliant data eye.

Required equipment

Example

Digital Timing Generator

Tektronix DTG5274 (up to 2.7 Gb)/DTG5334 (up to 3.4 Gb) with three
DTGM30 output module

2 differential probes; Ground lead

Tektronix P7313SMA; Tektronix part number 196-3469-00

8 SMA cables

Tektronix part number 174-1341-00, 1 meter, or
Tektronix part number 174-1428-00 1.5 meters

1 DC power supply, setto 3.3V

Kenwood PW18-1.8AQ

2 input adapters

EFF-HDMI -TPA-P and EFF-HDMI -TPA-R available from Efficere
Technologies

1. Click Select.
2. Click the Cable tab.

3. Click Configure. Change the values
if needed. (You can generally use the
default values.)

®  Test Points. For the first cable that
you test, select TP1 and TP2 to verify
both the input test signal (TP1) and
the output of the cable (TP2). For
successive cable tests, clear TP1.

m  CRU. Ensure that PLL (default) is
selected for compliance testing.

File | fests Results Utilities Help TDSHT3 || x
( So I's.ra
slec

nnnnn

Cable -» Eye Diagram Clock-» Ch1; Data-» Ch2; Rec Length -» 16M; CRU-= PLL; TP1 . True; TRZ-= True

File

Tests Results Utilies Help TDSHT3 | x|

Configure - Cal
[ Setup | DTG [ Cable Equaliz:
HoriziAcq High Ref
Rec Length
‘ 16.0M ¥
Mid Ref
Test Points 0
TP1 \/ TP2

nnnnn

CRU Low Ref

‘ FLL ¥
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4. Click the DTG tab. Configure which DTG
outputs will provide the clock and data
test signals.

5. Click the Cable Equalizer tab to select
the configuration options.

6. Click the Rise Time Filter tab to select
the configuration options.

32

File Tests Results Utilities Help TDSHT3 m x|

Pattern OQutputs

Select From List Al w

ik

B1 = [

Wiew
Waveform

Cable - Eye Diagram Clock-* Chi; Data -» Ch2: Rec Length -» 16M; CRU - PLL; TP1 - True; TP2 -> True

1961-069

File Tests Results Utililies Help TDSHT3 EJ Xl

Configure

Cannect from a file

View t apply equalizer ok and Data

Waveform

Cable - Eye Diagram Clock-* Ch1; Data -> Ch2; Rec Length -= 16M; CRU - PLL; TP1 -» True; TP2 -> True

1961-070

File | Tests Results Utilities Help TDSHT3 m x|

Confiqure - Cable

" pT6  [Cal ualizer [ Rise TThe Filter Run
Test

Rise Time Filter Configuration

Result
P ———

Rise Time Filter Path Report —|

Summary,

Cable -» Eya Diagram Clock-» Ch1; Data -> Ch2; Rec Length -» 16M; CRU -> PLL; TP1 -* True; TPZ-» True

1961-071
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7. Click Connect.

8. Connect and configure the equipment to
verify the test signal input:

m  Connect the test equipment as
shown in the TP1 setup diagram.

m  Connect the DTG and oscilloscope.
(See page 34, Enable Remote
Control of Test Equipment.)

NOTE. In the diagram, the CTERM D symbol
represents a 50 Q termination or an unused
probe input.

File | Tests Results Utilities Help

Connect

tructions to set up the connections.

Follow these
o" -

/
Wiew
i aweform

Cable - Eye Diagram

Signal
Sources

LAN

Application Examples

Clock-> Ch1; Data-> Ch2: Rec Length -> 16M:; CRU -> PLL: TP1-> True: TP2 -> True

TDSHT3

Run
Test

Report—|

1961072
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TTC Modules

E-Net to GPIB convertor

HDMI-TPA-R-TDR

]

®
7 oamap
DATAZN

7 oAt p
DATATN

= (7 oamaop

DATAON

<1 cooce

(] ClLOGKN  eemeemm
©

5
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[}
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— TERW )

E-Net

Digital Oscilloscope

HDMI- TPA - P
e DATRZP

) TERVD)
AT N

(CTERM )

it i DATAIN N
T ———CTErm)
ey DATALP.

=

NOTE. When you run sink or cable tests, a warning about GPIB Bus Timing appears. If you are sure that the bus timing
parameter is set to 2 msec, click OK to continue. Otherwise, click Cancel and change the bus timing parameter. (See

page 39, Set the GPIB Bus Timing.)
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9. Click Run Test.

10. Follow the series of on-screen
messages.

11. When the test completes, check the
test results. These results confirm that
the test signal input is compliant. (See
page 15, Interpret the Test Result.)

12. Remove the TPA-P-DI adapter and add
the TPA-R-DI adapter as shown in the
diagram.

NOTE. In the diagram, the symbol
represents a 50 Q termination or an unused
probe input.

13. Add the cable DUT between the
TPA-R-TDR adapters.

14. Click Run Test.

15. When the test completes, check the
test results. Pass indicates HDMI
compliance of the cable DUT. (See
page 15, Interpret the Test Result.)

16. Click Configure and set the test point
to TP2.

17. Replace the cable with another cable
DUT and click Run Test.

18. You can generate reports based on
the tests that you ran. (See page 17,
Generate and Print a Report.)

File Tests Results Utilities Help

TDsHT3 N | B X |

Report Configuration \

Result Summary: Cable
Pair (CK, D} Datal)

c]5-3: Cable Eye Diagram: TP2: CK. L(
Resolution 19207 1080i
Refresh Rate B0
e Report File
Wiew
W aveform
bl
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LAN

E-Net
Digital Oscilloscope

E-Net to GPIB convertor
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B (C_I DATAIN U’»(?W\

L ¢ S| oaaoN S\

& y \

il p———C (] CLOCK_P

———— g T ]
)
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Cable DUT

Enable Remote Control of Test Equipment

If you are using the specified Tektronix DTG and AWG models, the TDSHT3 software can configure the connected test
equipment automatically as you run tests. If you are using another DTG or AWG, you must configure the test equipment

manually.

Use this procedure to:

m  Connect the AWG and DTG for remote control

= Configure the GPIB address for remote control

You will need:

B Tektronix DTG5274 or DTG5334 and Tektronix AWG710 or AWG710B or AFG3000 (two channel model) or AWG7102

34
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= Tektronix TDS7000 series oscilloscope, DPO70000 series digital oscilloscope, or DSA70000 series digital oscilloscope
B National Instruments GPIB-USB-B with the included software, NI-488.2 for Windows

NI-488.2 Software configuration for TDS series

NOTE. If you already have NI-488.2 installed on your oscilloscope, ensure that you have the version and installation
parameters that are described in step 1. If you do not, then uninstall NI-488.2, and install it according to step 1.

1. Install NI-488.2 for Windows (version2.1
=\1-488.2 for Windows o] x|
or later). r—
. . . . Feature Tree N I _488 2“'
Dunng |nsta"at|on ﬂ Selectthe features to be installed. High Performance GPIB Suﬂ\:‘ale
2. Do not install NI-VISA. EREEI=TE

i+ =3 =| Driver and Applications
2 -| GPIB Analyzer

3. Install the Measurement & Automation @ =l Language Support

-3 ~| Microsoft C/C++

Explorer. = | Borland G/Ce+
23 +| Wisual Basic
= -] LabviEw
4. When prompted, enable the GPIB-USB - -- Ll iaos 5T
interface. o | NPASA 2B

72 ~| Measurement & Automation Explorer

5. Restart the oscilloscope.

©

Target Directory
| Browse |

DiskCost | <«Back bea>s | [ Gencel ]

1961-076

NI-Software configuration for DPO70000/DSA70000 series

NOTE. If you are using the NI-Drivers on the DPO70000/DSA70000 series for the first time, perform steps 6 through 14. If
not, perform steps 12 through 14.
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6. In the oscilloscope menu, click Utilities
> GPIB Configuration.

et Time & Date.

GFIB Configuration

Instrument Diagnosfics.
Emailon Eyent
Mltpurposs Knotss
Nevigaton Butons

U

P

RLi1.0K
August 22, 2006 11:11:36

1961077

7. In the GPIB configuration, select
Controller. A GPIB Mode Switch dialog
box is displayed.

8. Press OK to restart the oscilloscope.

GPIB Mode Switch 3]

Your osciloscopes operating
ot n order to

system must rebos
change GPIB modes,

Click OK ta reboat the system,

o i

ERlE GPIB/ nfiguration Adaress
Talk/ Listen Conuoller Off Bus 1
-— = -
—

1961078
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9. In the oscilloscope menu, click Utilities
> GPIB Configuration.

10. In the GPIB configuration, select
Talk/Listen. A GPIB mode switch dialog
box is displayed.

11. Press OK to restart the oscilloscope.

[ «mSoov [ 400ns 250.0Msis  4.0nsipt

RL:A.(

GPIB Configuration
Contraller Off Bus

1961079

You cannot access the NI software from
the Start > Program menu. Instead, go

T3 Add GPIB Hardware Wizard

toc: \Pr'og ram Fil es\Nati onal Ywelcome to the Add GRIE Hardware 'wizard,
Instr‘uments\NI—488 Z\B'I n Select an interface to add.
location GPIE-ENETA100 ~
' - . =+ Plug and Play Interface
12. Double-click on the Add GPIB Hardware eN: Fid o
. =
to display the Add GPIB Hardware o0 - PMC-GPIB
Wizard. B @
g = GPIB-USE-HS
13. Select the appropriate NI hardware from 1 - i
. . . G
the list (select GPIB-USB-B from the list = PCMCIA-GPIB+
if it is connected). Z v AT-GPIB/THT [Flug and Flay)
NI PCle-GPIB
M| ExpressCard-GPIE bt

14. Press Next and finish the installation.

Hext » ] [ Cancel

1961-080

NOTE. Do not install any NI drivers on the DPO70000 or DSA70000 series oscilloscope because they are preinstalled.
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Connect the Equipment

15. Connect the USB-GPIB controller to the
oscilloscope USB port. The oscilloscope
operating system detects the USB-GPIB
controller and installs the driver for it.

16. Using GPIB cables, connect (stack) the
DTG and AWG/AFG GPIB connectors to
the GPIB port of the GPIB controller.

If your test does not use the AWG/AFG,
connect the GPIB-USB-B between the

oscilloscope and the DTG, omitting the
stacked connector from the AWG/AFG.

Verify the Equipment Connections

17. Open the Measurement & Automation
Explorer that was installed with the
NI-488.2 software.

18. In the Configuration pane, under Devices
and Interfaces, right-click the GPIB
device.

19. Click Scan for Instruments.

20. Note the GPIB Instrument Number and
the Primary Address.

21. Right-click the instrument and click
Communicate with Instrument.

22. Click Query and check that *IDN?
describes the correct equipment.

@

(5

. usB
GPIB Oscilloscope
I o —
AWG Err“ - HEE=X=3) ﬁ!
0 J 0 @ b = [©
o B o =p HE6HEEERE
B = o o =
b
s )
H 4 ﬂkl coodd i}a
J J
GPIB (Stacked
DTG
: / connectors)
= - R | [;E:__j_]
[ ja—]=L
o GPIB-USB-B
| )
File Edit Mew Tools Hel)

@ Pmpartias | iScanForInstrumans ‘ ‘&"NISW 20 Analyzer
B |

4 show Hide

| Descripkion

TEKTRONIX,DTGS274,1300167
SONYITEK, AWGZ10,0,5CP199

] I

G
= G My System 1| ame I Ve
- B Devices and Interfaces | |1 o Torer/ce tmber 0
é ;E&S:;Iio (SRR (] Instrumencd Pr?mary Address ...
@ Remote Systems Instrumantl Primary Address ...
<
1 [ 21| o Avbutes |

4
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Set the GPIB Bus Timing

23. Right-click the GPIB device and click
Properties.

24. Click the Advanced tab.
25. In the Bus Timing list, select 2 usec.

26. Click OK. (Be sure that you complete

the procedure through step 38, where
you will exit the software and restart the

oscilloscope.)

¥ Measurement & Automation Explorer | =10l x|

File Edit Yiew Took Help

Application Examples

J Properties | '1Scan For Instruments l g NI Spy ":':L GPIE Analyzer

rz| GPIBO (GPIB-USB-B)

Configuration

LA My System

| Description

Remote Systems

<

Name | Yalue
=5 Q F)evices and Interfaces B PTG Interface Number O
é ?;ftizlrsau UL L:i_j] Instrumentd Primary Address ...
& Instrumentl Primary Address ...

TEKTROMIX,DTGS274, 1300167
SOMYITEK, AWGT10,0,5CP199

=]

[ | mw Avibutes

4

27 GPIB Configuration 2 %]

NI-498.2 Setings Advanced |

F GFIB-USE-B

IEDUnsec -
= @

Cable Length for HS488: Off >

Bus Timing:

Farallel Poll Duration:

¥ Automatic Setial Polling

I Assert BEMNwhen SC

’_ OK I Cancel
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Configure the GPIB Address

27. Start the TDSHT3 software.
28. Click Select.
29. Click the Sink tab.

30. Select a Differential test, such as Jitter
Tolerance.

31. Click Connect.
32. Click Signal Sources.

For the Tektronix DTG5274 or DTG5334
generator:

33. Click the DTG tab.

34. Click GPIB.

35. Click the AWG tab and repeat.
36. Click the AFG tab and repeat.

37. Click Test Conn and look for a message
that the connection is successful.

38. Exit the TDSHT3 software and restart
the oscilloscope.

Signal Sources Setup @ x|

B0 DTG e © 1 aFe

File Tests Results Utilities Heln TDSHT3 || x
—_Select - Sink

[T souws o Sink T ame | Run
Select

Differential Tests Single-Ended Tests Test
Contigure Result
Report—

View @
W/ aveform

Sink -> Jitter Tolerance Freq Pair= D,CK: S00kHz, 10MHz; DUT freq-» T425MHz; Test Opt.-» Altermnative-| | Jitter Insertion-= ...
1961085

File | Tests Results Utilities Help TDSHT3 m| x
Connect

Follow these instructions to set up the connections. Run
Test

Report—

Connect

Wiew
i/ aveform
Sink -> Jitter Tolerance Freq Pair> D,CK: S500kHZ A0MHz; DUT freq-» 74.26MHz; Test Opt-> Alternative-l ; Jitter Inserion-> ...
1961086

Select GPIB Setup
Board Type Address
GPIED ™ Primary

1 -

Secondary

] -

&
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Acquisition, 9
Advanced, 17
APP button, 10
Application examples, 19
Cable tests: Eye Diagram, 31
Sink tests: Jitter Tolerance, 26
Sink tests: Min/Max-Diff Swing
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Source tests: Inter-Pair
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AWG setup, 34
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Buttons, 7

C

Cable

Eye Diagram test, 31
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Calibrate probes, 5
Clear report, 17
Client pane, 7
Closing the application, 6
Configure, 13
Configure button, 12
Configure test equipment, 34
Configure the GPIB address, 40
Connect, 13
Connect button, 12
Connect test equipment, 34
Connections, 2

CSV file, 17
D
Detail, 18

Detailed report, 17
Device under test type, 7
Documentation, v

DTG setup, 34
DTG5274, 40

DUT Details, 18

DUT ID, 18

DUT type, 7

E

EDID emulator, 21
Efficere Technologies, 2
Enable Preview, 17, 18
Error codes, 15
Execution pane, 7

Exit button, 6

Exit the software, 6

F

Factory defaults, 13
File
Exit, 6
Preferences, 9
Run application, 3
Fine button, 9

G

General purpose knob, 9, 13

Generate a report, 17

Generator setup, 34

Get acquainted with the
application, 7

GPIB, 40

GPIB address, 40

GPIB bus timing, 39

H

Half Screen, 16
HDMI standards conformance, iv
Hide icon, 10
Hide the application, 10
How to
Install your software, 1
Make tests, 12
Operate the Application, 12

Installation, 1
Inter-Pair Skew test, 21
Interface, 7

J

Jitter Calibration, 28
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Jitter Tolerance test, 26
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Keyboard, 7
Knob, 9, 13

Make tests, 12

Menu bar, 7

Menus, 7

Min/Max-Diff Swing Tolerance
Test, 24

Mouse, 7

Multiple tests, 12

N

NI-488.2 Software Configuration for
DPO70000 series, 35

NI-488.2 Software Configuration for
TDS series, 35

0]

Oscilloscope general purpose
knob, 13

P

Pair, 17

Pixel clock rates, 21

Position eye mask in center, 9
Preferences, 9

Print a report, 17

Product description, iv

R

Recalculate Thit value, 24
Refresh Rate, 17
Related documentation, v
Remote control, 34
Report File, 17

Report file formats, 17
Report summary, 17
Resolution, 17

41



Index

Restore application, 11
Result Details, 15
Results, 15

Results button, 12
Return to the application, 10
RGT format, 17

RPL format, 17

RPT format, 17

RTF format, 17

Run Test, 14

Run Test button, 12

S

Safety Summary, iii
Select, 12

Select All, 12,19
Select button, 12
Select multiple tests, 12
Selection pane, 7

Set preferences, 9
Signal Sources, 40
Sink

Differential: Jitter Tolerance

test, 26

Differential: Min/Max-Diff Swing

Tolerance Test, 24
Software upgrades, v

42

Source

Data-Data: Inter-Pair Skew

test, 21
Source tab, 12
Source tests
Select All, 19
Start the application, 3
Status bar, 7
SVGA, 21

.

Thit value, 24

TekVisa, 1

Test Conn, 40

Test equipment, 34, 38
Connecting, 13
Setups, 2

Test ID, 12

Test ID 5-3, 31

Test ID 8-5, 24

Test ID 8-7, 26

Test parameters
Configuring, 13

Test results, 15

Tests
Process flow, 12

Touch screen, 7
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TPA-R-DI, 2
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TPA-R-TDR, 2
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Use oscilloscope settings for image
export, 18
Use the interface, 7

vV

VGA, 21

View test results, 15
View Waveform, 14
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Virtual keyboard, 7, 13
Virtual keypad, 8
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